aboutsummaryrefslogtreecommitdiffstats
path: root/drivers/crypto/qat/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'drivers/crypto/qat/meson.build')
-rw-r--r--drivers/crypto/qat/meson.build14
1 files changed, 14 insertions, 0 deletions
diff --git a/drivers/crypto/qat/meson.build b/drivers/crypto/qat/meson.build
new file mode 100644
index 00000000..7b904630
--- /dev/null
+++ b/drivers/crypto/qat/meson.build
@@ -0,0 +1,14 @@
+# SPDX-License-Identifier: BSD-3-Clause
+# Copyright(c) 2017 Intel Corporation
+
+dep = dependency('libcrypto', required: false)
+if not dep.found()
+ build = false
+endif
+sources = files('qat_crypto.c', 'qat_qp.c',
+ 'qat_adf/qat_algs_build_desc.c',
+ 'rte_qat_cryptodev.c')
+includes += include_directories('qat_adf')
+deps += ['bus_pci']
+ext_deps += dep
+pkgconfig_extra_libs += '-lcrypto'