aboutsummaryrefslogtreecommitdiffstats
path: root/drivers/net/bonding/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'drivers/net/bonding/meson.build')
-rw-r--r--drivers/net/bonding/meson.build11
1 files changed, 11 insertions, 0 deletions
diff --git a/drivers/net/bonding/meson.build b/drivers/net/bonding/meson.build
new file mode 100644
index 00000000..b90abc6d
--- /dev/null
+++ b/drivers/net/bonding/meson.build
@@ -0,0 +1,11 @@
+# SPDX-License-Identifier: BSD-3-Clause
+# Copyright(c) 2017 Intel Corporation
+
+name = 'bond' #, james bond :-)
+sources = files('rte_eth_bond_api.c', 'rte_eth_bond_pmd.c',
+ 'rte_eth_bond_args.c', 'rte_eth_bond_8023ad.c', 'rte_eth_bond_alb.c')
+
+deps += 'sched' # needed for rte_bitmap.h
+deps += ['ip_frag', 'cmdline']
+
+install_headers('rte_eth_bond.h', 'rte_eth_bond_8023ad.h')