aboutsummaryrefslogtreecommitdiffstats
path: root/examples/eventdev_pipeline/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'examples/eventdev_pipeline/meson.build')
-rw-r--r--examples/eventdev_pipeline/meson.build15
1 files changed, 15 insertions, 0 deletions
diff --git a/examples/eventdev_pipeline/meson.build b/examples/eventdev_pipeline/meson.build
new file mode 100644
index 00000000..0fc916b0
--- /dev/null
+++ b/examples/eventdev_pipeline/meson.build
@@ -0,0 +1,15 @@
+# SPDX-License-Identifier: BSD-3-Clause
+# Copyright(c) 2017 Intel Corporation
+
+# meson file, for building this example as part of a main DPDK build.
+#
+# To build this example as a standalone application with an already-installed
+# DPDK instance, use 'make'
+
+deps += 'eventdev'
+allow_experimental_apis = true
+sources = files(
+ 'main.c',
+ 'pipeline_worker_generic.c',
+ 'pipeline_worker_tx.c'
+)