aboutsummaryrefslogtreecommitdiffstats
path: root/lib/librte_cryptodev/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'lib/librte_cryptodev/meson.build')
-rw-r--r--lib/librte_cryptodev/meson.build10
1 files changed, 10 insertions, 0 deletions
diff --git a/lib/librte_cryptodev/meson.build b/lib/librte_cryptodev/meson.build
new file mode 100644
index 00000000..234da323
--- /dev/null
+++ b/lib/librte_cryptodev/meson.build
@@ -0,0 +1,10 @@
+# SPDX-License-Identifier: BSD-3-Clause
+# Copyright(c) 2017 Intel Corporation
+
+version = 3
+sources = files('rte_cryptodev.c', 'rte_cryptodev_pmd.c')
+headers = files('rte_cryptodev.h',
+ 'rte_cryptodev_pmd.h',
+ 'rte_crypto.h',
+ 'rte_crypto_sym.h')
+deps += ['kvargs', 'mbuf']