aboutsummaryrefslogtreecommitdiffstats
path: root/lib/librte_vhost/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'lib/librte_vhost/meson.build')
-rw-r--r--lib/librte_vhost/meson.build15
1 files changed, 15 insertions, 0 deletions
diff --git a/lib/librte_vhost/meson.build b/lib/librte_vhost/meson.build
new file mode 100644
index 00000000..9e8c0e76
--- /dev/null
+++ b/lib/librte_vhost/meson.build
@@ -0,0 +1,15 @@
+# SPDX-License-Identifier: BSD-3-Clause
+# Copyright(c) 2017 Intel Corporation
+
+if host_machine.system() != 'linux'
+ build = false
+endif
+if has_libnuma == 1
+ dpdk_conf.set10('RTE_LIBRTE_VHOST_NUMA', true)
+endif
+version = 4
+allow_experimental_apis = true
+sources = files('fd_man.c', 'iotlb.c', 'socket.c', 'vhost.c', 'vhost_user.c',
+ 'virtio_net.c')
+headers = files('rte_vhost.h')
+deps += ['ethdev']