aboutsummaryrefslogtreecommitdiffstats
path: root/HttpServer/app/build.gradle
diff options
context:
space:
mode:
Diffstat (limited to 'HttpServer/app/build.gradle')
-rw-r--r--HttpServer/app/build.gradle79
1 files changed, 79 insertions, 0 deletions
diff --git a/HttpServer/app/build.gradle b/HttpServer/app/build.gradle
new file mode 100644
index 00000000..4b30fccc
--- /dev/null
+++ b/HttpServer/app/build.gradle
@@ -0,0 +1,79 @@
+apply plugin: 'com.android.application'
+
+android {
+ compileSdkVersion 26
+ defaultConfig {
+ applicationId "icn.httpserver.com.httpserver"
+ minSdkVersion 24
+ targetSdkVersion 26
+ versionCode 2
+ versionName "1.0"
+ testInstrumentationRunner "android.support.test.runner.AndroidJUnitRunner"
+ externalNativeBuild {
+ cmake {
+ cppFlags "-std=c++11 -frtti -fexceptions -lz"
+ }
+ }
+ ndk {
+ // Specifies the ABI configurations of your native
+ // libraries Gradle should build and package with your APK.
+ abiFilters 'armeabi-v7a', 'x86'
+ }
+ }
+
+ signingConfigs {
+ release {
+ storeFile file("httpserver.keystore")
+ storePassword "httpserver"
+ keyAlias "httpserver"
+ keyPassword "httpserver"
+ }
+ }
+
+ buildTypes {
+ release {
+ minifyEnabled false
+ proguardFiles getDefaultProguardFile('proguard-android.txt'), 'proguard-rules.pro'
+ signingConfig signingConfigs.release
+ }
+ }
+
+ android.applicationVariants.all { variant ->
+ variant.outputs.all { output ->
+ def outputFile = output.outputFile
+ outputFile
+ if (outputFile != null && outputFile.name.endsWith('.apk')) {
+ project.ext {
+ appName = 'httpserver'}
+ def fileName = outputFile.name.replace("app",
+ "$project.ext.appName")
+ outputFileName = fileName
+
+ }
+
+ }
+ }
+
+ externalNativeBuild {
+ cmake {
+ path "CMakeLists.txt"
+ }
+ }
+ buildToolsVersion '26.0.2'
+ dexOptions {
+ incremental true
+ }
+ compileOptions {
+ sourceCompatibility JavaVersion.VERSION_1_8
+ targetCompatibility JavaVersion.VERSION_1_8
+ }
+}
+
+dependencies {
+ implementation fileTree(include: ['*.jar'], dir: 'libs')
+ implementation 'com.android.support:appcompat-v7:26.1.0'
+ implementation 'com.android.support.constraint:constraint-layout:1.0.2'
+ testImplementation 'junit:junit:4.12'
+ androidTestImplementation 'com.android.support.test:runner:1.0.1'
+ androidTestImplementation 'com.android.support.test.espresso:espresso-core:3.0.1'
+}