aboutsummaryrefslogtreecommitdiffstats
path: root/IGetAndroid/app/build.gradle
diff options
context:
space:
mode:
Diffstat (limited to 'IGetAndroid/app/build.gradle')
-rw-r--r--IGetAndroid/app/build.gradle73
1 files changed, 73 insertions, 0 deletions
diff --git a/IGetAndroid/app/build.gradle b/IGetAndroid/app/build.gradle
new file mode 100644
index 00000000..b17b0ae4
--- /dev/null
+++ b/IGetAndroid/app/build.gradle
@@ -0,0 +1,73 @@
+apply plugin: 'com.android.application'
+
+android {
+ compileSdkVersion 26
+ defaultConfig {
+ applicationId "icn.iget.com.igetandroid"
+ minSdkVersion 24
+ targetSdkVersion 26
+ versionCode 7
+ versionName "1.0"
+ testInstrumentationRunner "android.support.test.runner.AndroidJUnitRunner"
+ externalNativeBuild {
+ cmake {
+ cppFlags "-std=c++11 -frtti -fexceptions"
+ }
+ }
+
+ ndk {
+ // Specifies the ABI configurations of your native
+ // libraries Gradle should build and package with your APK.
+ abiFilters 'armeabi-v7a', 'arm64-v8a', 'x86', 'x86_64'
+ }
+ }
+
+
+ signingConfigs {
+ release {
+ storeFile file("iget.keystore")
+ storePassword "igetandroid"
+ keyAlias "iget"
+ keyPassword "igetandroid"
+ }
+ }
+
+ buildTypes {
+ release {
+ minifyEnabled false
+ proguardFiles getDefaultProguardFile('proguard-android.txt'), 'proguard-rules.pro'
+ signingConfig signingConfigs.release
+ }
+ }
+
+ android.applicationVariants.all { variant ->
+ variant.outputs.all { output ->
+ def outputFile = output.outputFile
+ outputFile
+ if (outputFile != null && outputFile.name.endsWith('.apk')) {
+ project.ext {
+ appName = 'iget'}
+ def fileName = outputFile.name.replace("app",
+ "$project.ext.appName")
+ outputFileName = fileName
+
+ }
+
+ }
+ }
+
+ externalNativeBuild {
+ cmake {
+ path "CMakeLists.txt"
+ }
+ }
+}
+
+dependencies {
+ implementation fileTree(dir: 'libs', include: ['*.jar'])
+ implementation 'com.android.support:appcompat-v7:26.1.0'
+ implementation 'com.android.support.constraint:constraint-layout:1.0.2'
+ testImplementation 'junit:junit:4.12'
+ androidTestImplementation 'com.android.support.test:runner:1.0.1'
+ androidTestImplementation 'com.android.support.test.espresso:espresso-core:3.0.1'
+}