aboutsummaryrefslogtreecommitdiffstats
path: root/MetisForwarder/app/build.gradle
diff options
context:
space:
mode:
Diffstat (limited to 'MetisForwarder/app/build.gradle')
-rw-r--r--MetisForwarder/app/build.gradle65
1 files changed, 0 insertions, 65 deletions
diff --git a/MetisForwarder/app/build.gradle b/MetisForwarder/app/build.gradle
deleted file mode 100644
index 18dd28c4..00000000
--- a/MetisForwarder/app/build.gradle
+++ /dev/null
@@ -1,65 +0,0 @@
-apply plugin: 'com.android.application'
-
-android {
- compileSdkVersion 25
- buildToolsVersion "25.0.2"
- defaultConfig {
- applicationId "metisforwarder.metis.com.metisforwarder"
- minSdkVersion 24
- targetSdkVersion 25
- versionCode 1
- versionName "1.0"
- testInstrumentationRunner "android.support.test.runner.AndroidJUnitRunner"
- externalNativeBuild {
- cmake {
- cppFlags "-frtti -fexceptions -Wno-error=format-security"
- }
- }
- ndk {
- // Specifies the ABI configurations of your native
- // libraries Gradle should build and package with your APK.
- abiFilters 'armeabi-v7a'
- }
- }
-
- signingConfigs {
- release {
- storeFile file("metisforwarder.keystore")
- storePassword "metisforwarder"
- keyAlias "metisforwarder"
- keyPassword "metisforwarder"
- }
- }
-
- buildTypes {
- release {
- minifyEnabled false
- proguardFiles getDefaultProguardFile('proguard-android.txt'), 'proguard-rules.pro'
- signingConfig signingConfigs.release
- applicationVariants.all { variant ->
- variant.outputs.each { output ->
- project.ext { appName = 'metis-forwarder' }
- def newName = output.outputFile.name
- newName = newName.replace("app", "$project.ext.appName-$System.env.ABI")
- output.outputFile = new File(output.outputFile.parent, newName)
- }
- }
- }
- }
- externalNativeBuild {
- cmake {
- path "CMakeLists.txt"
- }
- }
-
-}
-
-dependencies {
- compile fileTree(dir: 'libs', include: ['*.jar'])
- androidTestCompile('com.android.support.test.espresso:espresso-core:2.2.2', {
- exclude group: 'com.android.support', module: 'support-annotations'
- })
- compile 'com.android.support:appcompat-v7:25.2.0'
- compile 'com.android.support.constraint:constraint-layout:1.0.2'
- testCompile 'junit:junit:4.12'
-}