aboutsummaryrefslogtreecommitdiffstats
path: root/debian/patches/0003-build-mention-march-in-pkg-config-description.patch
diff options
context:
space:
mode:
authorLuca Boccassi <luca.boccassi@gmail.com>2019-01-22 11:21:50 +0000
committerLuca Boccassi <luca.boccassi@gmail.com>2019-01-22 13:58:54 +0000
commit5abe9a96f9966613bd415cfcefe1a76d9291d5c8 (patch)
tree393bae28dfada42c95ddf6f6ce7781e62908c5b1 /debian/patches/0003-build-mention-march-in-pkg-config-description.patch
parent03e22ee5491378244a0073c030efebec0b4fcdcf (diff)
Bump minimum meson version to 0.47.1 and backport patches
Fixes various bugs with Meson and dependencies parsing and generation. Change-Id: I2e7351e0954e16b1f4f928d2c09b653504fe8dc9 Signed-off-by: Luca Boccassi <luca.boccassi@gmail.com>
Diffstat (limited to 'debian/patches/0003-build-mention-march-in-pkg-config-description.patch')
-rw-r--r--debian/patches/0003-build-mention-march-in-pkg-config-description.patch20
1 files changed, 20 insertions, 0 deletions
diff --git a/debian/patches/0003-build-mention-march-in-pkg-config-description.patch b/debian/patches/0003-build-mention-march-in-pkg-config-description.patch
new file mode 100644
index 00000000..5b0af6fc
--- /dev/null
+++ b/debian/patches/0003-build-mention-march-in-pkg-config-description.patch
@@ -0,0 +1,20 @@
+Author: Luca Boccassi <bluca@debian.org>
+Description: mention -march in pkg-config description
+ Applications need to at least match DPDK's -march option to build
+ successfully due to some static inline functions in the public headers.
+ This might cause problems, especially in distributions, so add a note
+ in the pkg-config description.
+Origin: https://patches.dpdk.org/patch/49629/
+--- a/meson.build
++++ b/meson.build
+@@ -83,7 +83,9 @@ pkg.generate(name: meson.project_name(),
+ libraries: dpdk_libraries,
+ libraries_private: dpdk_drivers + dpdk_libraries +
+ ['-Wl,-Bdynamic'] + dpdk_extra_ldflags,
+- description: 'The Data Plane Development Kit (DPDK)',
++ description: '''The Data Plane Development Kit (DPDK).
++Note that CFLAGS might contain an -march flag higher than typical baseline.
++This is required for a number of static inline functions in the public headers.''',
+ subdirs: [get_option('include_subdir_arch'), '.'],
+ extra_cflags: ['-include', 'rte_config.h'] + machine_args
+ )