Description: mk: use make silent flag to print HTML doc version
Depending on the environment, make might echo the command being ran.
In mk/rte.sdkdoc.mk make is used to print the DPDK version to be
piped to doxygen. This causes the following to be written:
DPDK
/usr/bin/make-f/build/dpdk-jYjqnr/dpdk-16.11.2/mk/rte.sdkconfig.mkshowversion
Use -s (--silent) to prevent echoing.
Origin: http://dpdk.org/dev/patchwork/patch/25673/
Forwarded: yes
Author: Luca Boccassi
Last-Update: 2017-06-24
---
mk/rte.sdkdoc.mk | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/mk/rte.sdkdoc.mk b/mk/rte.sdkdoc.mk
index fb8f91555..c0eaa3502 100644
--- a/mk/rte.sdkdoc.mk
+++ b/mk/rte.sdkdoc.mk
@@ -73,7 +73,7 @@ api-html: $(API_EXAMPLES)
$(Q)mkdir -p $(RTE_OUTPUT)/doc/html
$(Q)(cat $(RTE_SDK)/doc/api/doxy-api.conf && \
printf 'PROJECT_NUMBER = ' && \
- $(MAKE) -rR showversion && \
+ $(MAKE) -rRs showversion && \
echo INPUT += $(API_EXAMPLES) && \
echo OUTPUT_DIRECTORY = $(RTE_OUTPUT)/doc && \
echo HTML_OUTPUT = html/api && \
--
2.11.0