summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorMauro Sardara <msardara@cisco.com>2019-01-22 00:02:05 +0100
committerMauro Sardara <msardara@cisco.com>2019-01-22 14:38:36 +0100
commit211b6a8bc6d959a874a43f28d4cda43eae48200d (patch)
treeba0385073c4c2f9baaf611a7f2c7a1e38d507edc /CMakeLists.txt
parent7d710d62fcb2a15505a7a0fc8feb91b8342fafd6 (diff)
[HICN-3] First version of packaging system based on cmake.
Change-Id: I576f84f4c12f932e17e9169f2c6ffdaed128ca10 Signed-off-by: Mauro Sardara <msardara@cisco.com>
Diffstat (limited to 'CMakeLists.txt')
-rwxr-xr-xCMakeLists.txt11
1 files changed, 8 insertions, 3 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index c47f8e640..a362a4005 100755
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -27,8 +27,10 @@ set(LIBHICN_SHARED hicn.shared)
set(LIBHICN_LIGHT hicn-light)
set(HICN_LIGHT_CONTROL hicnLightControl)
set(HICN_LIGHT_DAEMON hicnLightDaemon)
-set(LIBTRANSPORT transport)
-set(LIBTRANSPORT_SHARED transport.shared)
+set(HICN_PLUGIN hicn-plugin)
+set(LIBTRANSPORT hicntransport)
+set(LIBTRANSPORT_SHARED hicntransport.shared)
+set(HICN_UTILS hicn-utils)
## HEADER FILES
set(LIBHICN_HEADER_FILES)
@@ -48,4 +50,7 @@ endif()
foreach(dir ${SUBDIRS})
add_subdirectory(${dir})
-endforeach() \ No newline at end of file
+endforeach()
+
+include(Packager)
+make_packages() \ No newline at end of file