summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorAngelo Mantellini <manangel@cisco.com>2019-02-13 17:27:33 +0100
committerAngelo Mantellini <manangel@cisco.com>2019-02-13 18:41:25 +0100
commit2ba6db73e9a319b665853d65682230be98dde8d9 (patch)
tree77522585bb9c365e85fd4dfde8bb8eaeb9a66f15 /CMakeLists.txt
parent2f039d41169b95fa1ee9b1be9fbdc8e899707d25 (diff)
[HICN-61] Compile Error in libtransport in windows environment
Change-Id: I25642a194996e449b91d492b22a379466c524940 Signed-off-by: Angelo Mantellini <manangel@cisco.com>
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt4
1 files changed, 3 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 973946c6f..ff8c87002 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -82,7 +82,9 @@ endif()
set(LIBHICN_SHARED ${LIBHICN}.shared)
set(LIBTRANSPORT_SHARED ${LIBTRANSPORT}.shared)
-add_compile_options(-Wall -Werror)
+if (NOT WIN32)
+ add_compile_options(-Wall -Werror)
+endif ()
message(STATUS "Building the following subprojects: ${subdirs}")