summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorMauro Sardara <msardara@cisco.com>2019-01-29 16:39:50 +0100
committerMauro Sardara <msardara@cisco.com>2019-01-29 17:22:02 +0100
commit92bce6034ead88d1a11b5bdacd975a9d4cbec795 (patch)
treebe7a991d732881bae27664919e3fc9860327fc26 /CMakeLists.txt
parent317c2f8e695de186487347117296faa04ed42269 (diff)
[HICN-10] Treat warning as errors in compilation during verify jobs.
Change-Id: Iab6deb14157f81c9f2f8ba6762e93e9860b108bd Signed-off-by: Mauro Sardara <msardara@cisco.com>
Diffstat (limited to 'CMakeLists.txt')
-rwxr-xr-xCMakeLists.txt16
1 files changed, 10 insertions, 6 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index a362a4005..29fa1700b 100755
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -39,13 +39,17 @@ set(LIBTRANSPORT_HEADER_FILES)
set(SUBDIRS lib hicn-light libtransport utils)
+add_compile_options(-Wall -Werror)
+
if (BUILD_VPP_PLUGIN AND "${CMAKE_SYSTEM_NAME}" STREQUAL "Linux" )
-list(APPEND SUBDIRS
- hicn-plugin
-)
-list(APPEND HICN_BINARY_API_INCLUDE_DIRS
- ${PROJECT_BINARY_DIR}/hicn-plugin
- ${PROJECT_BINARY_DIR}/hicn-plugin/vpp_plugins)
+ list(APPEND SUBDIRS
+ hicn-plugin
+ )
+
+ list(APPEND HICN_BINARY_API_INCLUDE_DIRS
+ ${PROJECT_BINARY_DIR}/hicn-plugin
+ ${PROJECT_BINARY_DIR}/hicn-plugin/vpp_plugins
+ )
endif()
foreach(dir ${SUBDIRS})