summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorAlberto Compagno <acompagn+fdio@cisco.com>2019-03-23 15:14:39 +0000
committerGerrit Code Review <gerrit@fd.io>2019-03-23 15:14:39 +0000
commitdfc988a222a38da36999395e393e3b1ed1ccdfde (patch)
tree73a34d2f778f8cae62d3a72d38aa63f8c2a28d80 /CMakeLists.txt
parenta2bdc00ea25f89185c1095a48a8f51cb2c1a20e6 (diff)
parent1ad06afe9f952642a26f4d28239cf05eb3283eb7 (diff)
Merge "[HICN-6] ATS Working, little refactoring of apps"
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt4
1 files changed, 2 insertions, 2 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index a2cd8edd7..9a4136e3e 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -26,7 +26,7 @@ option(BUILD_LIBHICN "Build the hicn core library" ON)
option(BUILD_HICNLIGHT "Build the hicn light forwarder" ON)
option(BUILD_LIBTRANSPORT "Build the hicn transport library" ON)
option(BUILD_UTILS "Build the hicn utils" ON)
-option(BUILD_APPS "Build the hicn apps" ON)
+option(BUILD_APPS "Build the hicn apps" OFF)
option(BUILD_HICNPLUGIN "Build the hicn vpp plugin" OFF)
list(APPEND dir_options
@@ -68,7 +68,7 @@ set(LIBTRANSPORT hicntransport)
set(HICN_UTILS hicn-utils)
set(HICN_APPS hicn-apps)
-if (BUILD_HICNPLUGIN AND "${CMAKE_SYSTEM_NAME}" STREQUAL "Linux" )
+if (BUILD_HICNPLUGIN AND "${CMAKE_SYSTEM_NAME}" STREQUAL "Linux")
list(APPEND subdirs
${BUILD_HICNPLUGIN_DIR}
)