aboutsummaryrefslogtreecommitdiffstats
path: root/hicn-plugin/CMakeLists.txt
diff options
context:
space:
mode:
authorAberto Compagno <acompagn+fdio@cisco.com>2020-01-29 15:52:45 +0000
committerAberto Compagno <acompagn+fdio@cisco.com>2020-01-29 15:52:45 +0000
commitfa11d711aaab5e4cba7e89dcc896866f3e73db3f (patch)
tree77354d17548fe42a9595565c36fbd6376ce46e18 /hicn-plugin/CMakeLists.txt
parenteebfbba8a21e5cfa7e09abbcd601d9b0521b2353 (diff)
[HICN-491] Fixed missing inclusion of vapi_safe into the hicn-plugin deb/rpm packagev20.01
Signed-off-by: Aberto Compagno <acompagn+fdio@cisco.com> Change-Id: Iec88cca235395754829fedf029add5fa779d5a9e
Diffstat (limited to 'hicn-plugin/CMakeLists.txt')
-rw-r--r--hicn-plugin/CMakeLists.txt24
1 files changed, 24 insertions, 0 deletions
diff --git a/hicn-plugin/CMakeLists.txt b/hicn-plugin/CMakeLists.txt
index d0781e8fa..038426838 100644
--- a/hicn-plugin/CMakeLists.txt
+++ b/hicn-plugin/CMakeLists.txt
@@ -13,6 +13,30 @@
cmake_minimum_required(VERSION 3.5 FATAL_ERROR)
+project(hicn-plugin)
+
+include(GNUInstallDirs)
+
+set(CMAKE_MODULE_PATH ${CMAKE_MODULE_PATH}
+ "${CMAKE_CURRENT_SOURCE_DIR}/../cmake/Modules/"
+ "${CMAKE_CURRENT_SOURCE_DIR}/cmake/Modules/"
+)
+include(BuildMacros)
+
+set (CMAKE_CXX_STANDARD 11)
+set (CMAKE_C_STANDARD 11)
+
+# Check for memfd_create syscall
+include(CheckSymbolExists)
+CHECK_SYMBOL_EXISTS ( "__NR_memfd_create" "sys/syscall.h" HAVE_MEMFD_CREATE )
+if ( HAVE_MEMFD_CREATE )
+ add_definitions ( -DHAVE_MEMFD_CREATE )
+endif()
+
+set(HICN_PLUGIN hicn-plugin CACHE INTERNAL "" FORCE)
+
+include (Packaging)
+
add_subdirectory(src)
add_subdirectory(vapi) \ No newline at end of file