aboutsummaryrefslogtreecommitdiffstats
path: root/hicn-plugin/vapi/CMakeLists.txt
diff options
context:
space:
mode:
authorMauro Sardara <msardara@cisco.com>2020-03-24 17:34:14 +0000
committerMauro Sardara <msardara@cisco.com>2020-09-14 17:31:15 +0000
commit88509fe353767cbde707c3e3b1f29392957819f3 (patch)
treecccd51bac7966cd3138c525e8075d90341184a66 /hicn-plugin/vapi/CMakeLists.txt
parentd875ae92a7fa1eaab3bc2616aeeedfc64a81fea4 (diff)
[HICN-574] Host stack plugin for VPP.
Signed-off-by: Mauro Sardara <msardara@cisco.com> Change-Id: I8d8fdffef31a7013265d6529c5f52f3d5ec70d18 Signed-off-by: Mauro Sardara <msardara@cisco.com> Signed-off-by: Mauro <you@example.com> Signed-off-by: Mauro Sardara <msardara@cisco.com>
Diffstat (limited to 'hicn-plugin/vapi/CMakeLists.txt')
-rw-r--r--hicn-plugin/vapi/CMakeLists.txt3
1 files changed, 2 insertions, 1 deletions
diff --git a/hicn-plugin/vapi/CMakeLists.txt b/hicn-plugin/vapi/CMakeLists.txt
index 03fd489ca..382ccc34a 100644
--- a/hicn-plugin/vapi/CMakeLists.txt
+++ b/hicn-plugin/vapi/CMakeLists.txt
@@ -32,6 +32,7 @@ set (LIBRARIES
${VPP_LIBRARY_VAPICLIENT})
list (APPEND INCLUDE_DIRS
+ ${HICNPLUGIN_INCLUDE_DIRS}
${VPP_INCLUDE_DIR}
${CMAKE_CURRENT_SOURCE_DIR}/include)
@@ -42,7 +43,7 @@ build_library(${SAFE_VAPI}
LINK_LIBRARIES ${LIBRARIES}
COMPONENT ${HICN_PLUGIN}
INCLUDE_DIRS ${INCLUDE_DIRS}
- INSTALL_ROOT_DIR /
+ HEADER_ROOT_DIR /
DEFINITIONS ${COMPILER_DEFINITIONS}
)