aboutsummaryrefslogtreecommitdiffstats
path: root/apps/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'apps/CMakeLists.txt')
-rw-r--r--apps/CMakeLists.txt8
1 files changed, 2 insertions, 6 deletions
diff --git a/apps/CMakeLists.txt b/apps/CMakeLists.txt
index 5737a1d09..9b9011800 100644
--- a/apps/CMakeLists.txt
+++ b/apps/CMakeLists.txt
@@ -49,15 +49,11 @@ else()
)
endif()
-set(SUFFIX "")
-if (${LIBTRANSPORT_LIBRARIES} MATCHES ".*-memif.*")
- set(DEPENDENCIES ${LIBMEMIF_SHARED})
- set(SUFFIX "-memif")
+# Worksroung for unresolved symbols in vpp libraries
+if(${CMAKE_SYSTEM_NAME} MATCHES Linux)
set(LINK_FLAGS "-Wl,-unresolved-symbols=ignore-in-shared-libs")
endif()
-set(HICN_APPS "${HICN_APPS}${SUFFIX}")
-
list(APPEND LIBRARIES
${LIBTRANSPORT_LIBRARIES}
${LIBHICNCTRL_LIBRARIES}