aboutsummaryrefslogtreecommitdiffstats
path: root/hicn-plugin/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'hicn-plugin/CMakeLists.txt')
-rw-r--r--hicn-plugin/CMakeLists.txt24
1 files changed, 24 insertions, 0 deletions
diff --git a/hicn-plugin/CMakeLists.txt b/hicn-plugin/CMakeLists.txt
index d0781e8fa..038426838 100644
--- a/hicn-plugin/CMakeLists.txt
+++ b/hicn-plugin/CMakeLists.txt
@@ -13,6 +13,30 @@
cmake_minimum_required(VERSION 3.5 FATAL_ERROR)
+project(hicn-plugin)
+
+include(GNUInstallDirs)
+
+set(CMAKE_MODULE_PATH ${CMAKE_MODULE_PATH}
+ "${CMAKE_CURRENT_SOURCE_DIR}/../cmake/Modules/"
+ "${CMAKE_CURRENT_SOURCE_DIR}/cmake/Modules/"
+)
+include(BuildMacros)
+
+set (CMAKE_CXX_STANDARD 11)
+set (CMAKE_C_STANDARD 11)
+
+# Check for memfd_create syscall
+include(CheckSymbolExists)
+CHECK_SYMBOL_EXISTS ( "__NR_memfd_create" "sys/syscall.h" HAVE_MEMFD_CREATE )
+if ( HAVE_MEMFD_CREATE )
+ add_definitions ( -DHAVE_MEMFD_CREATE )
+endif()
+
+set(HICN_PLUGIN hicn-plugin CACHE INTERNAL "" FORCE)
+
+include (Packaging)
+
add_subdirectory(src)
add_subdirectory(vapi) \ No newline at end of file