aboutsummaryrefslogtreecommitdiffstats
path: root/utils/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'utils/CMakeLists.txt')
-rwxr-xr-xutils/CMakeLists.txt54
1 files changed, 54 insertions, 0 deletions
diff --git a/utils/CMakeLists.txt b/utils/CMakeLists.txt
new file mode 100755
index 000000000..95fdd508d
--- /dev/null
+++ b/utils/CMakeLists.txt
@@ -0,0 +1,54 @@
+# Copyright (c) 2017-2019 Cisco and/or its affiliates.
+# Licensed under the Apache License, Version 2.0 (the "License");
+# you may not use this file except in compliance with the License.
+# You may obtain a copy of the License at:
+#
+# http://www.apache.org/licenses/LICENSE-2.0
+#
+# Unless required by applicable law or agreed to in writing, software
+# distributed under the License is distributed on an "AS IS" BASIS,
+# WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
+# See the License for the specific language governing permissions and
+# limitations under the License.
+
+cmake_minimum_required(VERSION 3.5 FATAL_ERROR)
+set(CMAKE_CXX_STANDARD 14)
+
+project(Utils)
+
+set(CMAKE_MODULE_PATH
+ ${CMAKE_MODULE_PATH}
+ "${CMAKE_CURRENT_SOURCE_DIR}/../cmake/Modules"
+ "${CMAKE_CURRENT_SOURCE_DIR}/cmake/Modules"
+)
+
+include(BuildMacros)
+include(Packager)
+
+if(CMAKE_SOURCE_DIR STREQUAL PROJECT_SOURCE_DIR)
+ find_package(Libtransport REQUIRED)
+else()
+ # TODO Set name of targets in CMakeroot file
+ set(LIBTRANSPORT_LIBRARIES ${LIBTRANSPORT})
+endif()
+
+set (COMPILER_DEFINITIONS "-DASIO_STANDALONE")
+
+list(APPEND UTILS_SRC
+ src/hiperf.cc
+ src/ping_client.cc
+ src/ping_server.cc
+)
+
+foreach(util ${UTILS_SRC})
+ get_filename_component(_util_name ${util} NAME)
+ string(REGEX REPLACE ".cc" "" util_name ${_util_name})
+
+ build_executable(${util_name}
+ SOURCES ${util}
+ LINK_LIBRARIES ${LIBTRANSPORT_LIBRARIES}
+ DEPENDS transport
+ COMPONENT utils
+ DEFINITIONS ${COMPILER_DEFINITIONS}
+ )
+endforeach() \ No newline at end of file