summaryrefslogtreecommitdiffstats
path: root/common/scripts-parent/pom.xml
diff options
context:
space:
mode:
Diffstat (limited to 'common/scripts-parent/pom.xml')
-rw-r--r--common/scripts-parent/pom.xml24
1 files changed, 20 insertions, 4 deletions
diff --git a/common/scripts-parent/pom.xml b/common/scripts-parent/pom.xml
index 82bbf4f..374bee3 100644
--- a/common/scripts-parent/pom.xml
+++ b/common/scripts-parent/pom.xml
@@ -28,10 +28,10 @@
<properties>
<!-- groovy -->
- <maven.groovy.version>2.0</maven.groovy.version>
- <groovy.version>2.4.7</groovy.version>
- <groovy.eclipse.compiler.version>2.9.2-01</groovy.eclipse.compiler.version>
- <groovy.eclipse.batch.version>2.4.3-01</groovy.eclipse.batch.version>
+ <maven.groovy.version>1.6.2</maven.groovy.version>
+ <groovy.version>2.5.5</groovy.version>
+ <groovy.eclipse.compiler.version>3.3.0-01</groovy.eclipse.compiler.version>
+ <groovy.eclipse.batch.version>2.5.6-02</groovy.eclipse.batch.version>
<odl.yang-binding.version>0.13.2</odl.yang-binding.version>
</properties>
@@ -41,6 +41,12 @@
<groupId>org.codehaus.groovy</groupId>
<artifactId>groovy-all</artifactId>
<version>${groovy.version}</version>
+ <type>pom</type>
+ </dependency>
+ <dependency>
+ <groupId>org.codehaus.groovy</groupId>
+ <artifactId>groovy-templates</artifactId>
+ <version>${groovy.version}</version>
</dependency>
<dependency>
<groupId>org.opendaylight.mdsal</groupId>
@@ -72,9 +78,12 @@
</plugin>
<plugin>
<artifactId>maven-compiler-plugin</artifactId>
+ <version>3.8.0</version>
<!-- 2.8.0-01 and later require maven-compiler-plugin 3.1 or higher -->
<configuration>
<compilerId>groovy-eclipse-compiler</compilerId>
+ <source>1.8</source>
+ <target>1.8</target>
</configuration>
<dependencies>
<dependency>
@@ -83,11 +92,18 @@
<version>${groovy.eclipse.compiler.version}</version>
</dependency>
<!-- for 2.8.0-01 and later you must have an explicit dependency on groovy-eclipse-batch -->
+ <!-- https://mvnrepository.com/artifact/org.codehaus.groovy/groovy-eclipse-batch -->
<dependency>
<groupId>org.codehaus.groovy</groupId>
<artifactId>groovy-eclipse-batch</artifactId>
<version>${groovy.eclipse.batch.version}</version>
</dependency>
+ <dependency>
+ <groupId>org.codehaus.groovy</groupId>
+ <artifactId>groovy-all</artifactId>
+ <version>${groovy.version}</version>
+ <type>pom</type>
+ </dependency>
</dependencies>
</plugin>
</plugins>