aboutsummaryrefslogtreecommitdiffstats
path: root/vpp/g2/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'vpp/g2/Makefile.am')
-rw-r--r--vpp/g2/Makefile.am34
1 files changed, 34 insertions, 0 deletions
diff --git a/vpp/g2/Makefile.am b/vpp/g2/Makefile.am
new file mode 100644
index 00000000..8457c272
--- /dev/null
+++ b/vpp/g2/Makefile.am
@@ -0,0 +1,34 @@
+# Copyright (c) 2016 Cisco and/or its affiliates.
+# Licensed under the Apache License, Version 2.0 (the "License");
+# you may not use this file except in compliance with the License.
+# You may obtain a copy of the License at:
+#
+# http://www.apache.org/licenses/LICENSE-2.0
+#
+# Unless required by applicable law or agreed to in writing, software
+# distributed under the License is distributed on an "AS IS" BASIS,
+# WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
+# See the License for the specific language governing permissions and
+# limitations under the License.
+
+AUTOMAKE_OPTIONS = foreign
+
+bin_PROGRAMS = g2
+
+AM_CFLAGS = -Wall
+
+g2_SOURCES = \
+ clib.c \
+ cpel.c \
+ cpel.h \
+ events.c \
+ g2.h \
+ main.c \
+ menu1.c \
+ pointsel.c \
+ props.c \
+ props.h \
+ g2version.c \
+ view1.c
+
+g2_LDADD = $(g2_LIBS) -lvppinfra -lpthread -lm