aboutsummaryrefslogtreecommitdiffstats
path: root/vpp/perftool/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'vpp/perftool/configure.ac')
-rw-r--r--vpp/perftool/configure.ac12
1 files changed, 12 insertions, 0 deletions
diff --git a/vpp/perftool/configure.ac b/vpp/perftool/configure.ac
new file mode 100644
index 00000000..f4a98697
--- /dev/null
+++ b/vpp/perftool/configure.ac
@@ -0,0 +1,12 @@
+AC_INIT(perftool, 2.0)
+AM_INIT_AUTOMAKE
+AM_SILENT_RULES([yes])
+
+AC_CHECK_LIB([vppinfra], [clib_mem_get_page_size],,
+ AC_MSG_ERROR([Please install the vpp-lib package]))
+AC_CHECK_HEADER([vppinfra/clib.h],,
+ AC_MSG_ERROR([Please install the vpp-dev package]))
+
+AM_PROG_LIBTOOL
+
+AC_OUTPUT([Makefile])