aboutsummaryrefslogtreecommitdiffstats
path: root/vpp/plugins/lb-plugin/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'vpp/plugins/lb-plugin/Makefile.am')
-rw-r--r--vpp/plugins/lb-plugin/Makefile.am55
1 files changed, 55 insertions, 0 deletions
diff --git a/vpp/plugins/lb-plugin/Makefile.am b/vpp/plugins/lb-plugin/Makefile.am
new file mode 100644
index 00000000..8e360279
--- /dev/null
+++ b/vpp/plugins/lb-plugin/Makefile.am
@@ -0,0 +1,55 @@
+# Copyright (c) 2016 Cisco Systems, Inc.
+# Licensed under the Apache License, Version 2.0 (the "License");
+# you may not use this file except in compliance with the License.
+# You may obtain a copy of the License at:
+#
+# http://www.apache.org/licenses/LICENSE-2.0
+#
+# Unless required by applicable law or agreed to in writing, software
+# distributed under the License is distributed on an "AS IS" BASIS,
+# WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
+# See the License for the specific language governing permissions and
+# limitations under the License.
+
+AUTOMAKE_OPTIONS = foreign subdir-objects
+
+AM_CFLAGS = -Wall
+AM_LDFLAGS = -module -shared -avoid-version
+
+vppapitestpluginsdir = ${libdir}/vpp_api_test_plugins
+vpppluginsdir = ${libdir}/vpp_plugins
+
+vppapitestplugins_LTLIBRARIES = lb_test_plugin.la
+vppplugins_LTLIBRARIES = lb_plugin.la
+
+lb_plugin_la_SOURCES = lb/lb.c lb/node.c lb/cli.c lb/util.c lb/refcount.c lb/api.c
+
+BUILT_SOURCES = \
+ lb/lb.api.h \
+ lb/lb.api.json
+
+SUFFIXES = .api.h .api .api.json
+
+%.api.h: %.api
+ mkdir -p `dirname $@` ; \
+ $(CC) $(CPPFLAGS) -E -P -C -x c $^ \
+ | vppapigen --input - --output $@ --show-name $@
+
+%.api.json: %.api
+ @echo " JSON APIGEN " $@ ; \
+ mkdir -p `dirname $@` ; \
+ $(CC) $(CPPFLAGS) -E -P -C -x c $^ \
+ | vppapigen --input - --json $@
+
+apidir = $(prefix)/lb/
+api_DATA = lb/lb.api.json
+
+noinst_HEADERS = lb/lb.h lb/util.h lb/refcount.h lb/lbhash.h lb/lb.api.h
+
+lb_test_plugin_la_SOURCES = \
+ lb/lb_test.c lb/lb_plugin.api.h
+
+# Remove *.la files
+install-data-hook:
+ @(cd $(vpppluginsdir) && $(RM) $(vppplugins_LTLIBRARIES))
+ @(cd $(vppapitestpluginsdir) && $(RM) $(vppapitestplugins_LTLIBRARIES))