aboutsummaryrefslogtreecommitdiffstats
path: root/vpp/vlib/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'vpp/vlib/configure.ac')
-rw-r--r--vpp/vlib/configure.ac25
1 files changed, 25 insertions, 0 deletions
diff --git a/vpp/vlib/configure.ac b/vpp/vlib/configure.ac
new file mode 100644
index 00000000..f7079e64
--- /dev/null
+++ b/vpp/vlib/configure.ac
@@ -0,0 +1,25 @@
+AC_INIT(vlib, 1.1)
+LT_INIT
+AM_INIT_AUTOMAKE
+AM_SILENT_RULES([yes])
+
+AC_PROG_CC
+
+AC_ARG_WITH(dpdk,
+ AC_HELP_STRING([--with-dpdk],[Use DPDK]),
+ [with_dpdk=1],
+ [with_dpdk=0])
+
+AC_ARG_WITH(pre-data,
+ AC_HELP_STRING([--with-pre-data],[Set buffer rewrite space]),
+ [case $with_pre_data in
+ 128) ;;
+ 256) ;;
+ *) with_pre_data="pre-data-not-set" ;;
+ esac], [with_pre_data=128])
+
+AM_CONDITIONAL(WITH_DPDK, test "$with_dpdk" = "1")
+AC_SUBST(DPDK,[-DDPDK=${with_dpdk}])
+AC_SUBST(PRE_DATA_SIZE,[$with_pre_data])
+
+AC_OUTPUT([Makefile])