aboutsummaryrefslogtreecommitdiffstats
path: root/vpp/vpp/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'vpp/vpp/configure.ac')
-rw-r--r--vpp/vpp/configure.ac7
1 files changed, 6 insertions, 1 deletions
diff --git a/vpp/vpp/configure.ac b/vpp/vpp/configure.ac
index d36695cc..e1a5d7df 100644
--- a/vpp/vpp/configure.ac
+++ b/vpp/vpp/configure.ac
@@ -34,12 +34,17 @@ AC_ARG_WITH(ipv6sr,
[with_ipv6sr=0],
[with_ipv6sr=1])
+AC_ARG_WITH(odplib,
+ AC_HELP_STRING([--with-odplib],[Use odp]),
+ [with_odplib=1],
+ [with_odplib=0])
+
AM_CONDITIONAL(WITH_DPDK, test "$with_dpdk" = "1")
AM_CONDITIONAL(ENABLE_DPDK_SHARED, test "$enable_dpdk_shared" = "1")
AC_SUBST(DPDK,["-DDPDK=${with_dpdk} -DDPDK_SHARED_LIB=${enable_dpdk_shared}"])
AM_CONDITIONAL(WITH_DPDK_CRYPTO, test "$with_dpdk_crypto" = "1")
AC_SUBST(DPDK_CRYPTO,[-DDPDK_CRYPTO=${with_dpdk_crypto}])
-
+AM_CONDITIONAL(WITH_ODPLIB, test "$with_odplib" = "1")
AM_COND_IF(
[ENABLE_DPDK_SHARED],