aboutsummaryrefslogtreecommitdiffstats
path: root/app/nginx/src/http/modules/perl/Makefile.PL
diff options
context:
space:
mode:
Diffstat (limited to 'app/nginx/src/http/modules/perl/Makefile.PL')
-rw-r--r--app/nginx/src/http/modules/perl/Makefile.PL35
1 files changed, 35 insertions, 0 deletions
diff --git a/app/nginx/src/http/modules/perl/Makefile.PL b/app/nginx/src/http/modules/perl/Makefile.PL
new file mode 100644
index 0000000..7edadcb
--- /dev/null
+++ b/app/nginx/src/http/modules/perl/Makefile.PL
@@ -0,0 +1,35 @@
+
+# Copyright (C) Igor Sysoev
+# Copyright (C) Nginx, Inc.
+
+use 5.006001;
+use ExtUtils::MakeMaker;
+
+WriteMakefile(
+ NAME => 'nginx',
+ VERSION_FROM => 'nginx.pm', # finds $VERSION
+ PREREQ_PM => {}, # e.g., Module::Name => 1.1
+
+ ABSTRACT_FROM => 'nginx.pm', # retrieve abstract from module
+ AUTHOR => 'Igor Sysoev',
+
+ CCFLAGS => "$ENV{NGX_PM_CFLAGS}",
+ OPTIMIZE => '-O',
+
+ LDDLFLAGS => "$ENV{NGX_PM_LDFLAGS}",
+
+ INC => join(" ", map {
+ m#^/# ? "-I $_" : "-I ../../../../../$_"
+ } (split /\s+/, $ENV{NGX_INCS})),
+
+ depend => {
+ 'nginx.c' => join(" ", map {
+ m#^/# ? $_ : "../../../../../$_"
+ } (split(/\s+/, $ENV{NGX_DEPS}),
+ "src/http/modules/perl/ngx_http_perl_module.h"))
+ },
+
+ PM => {
+ 'nginx.pm' => '$(INST_LIBDIR)/nginx.pm'
+ }
+);