summaryrefslogtreecommitdiffstats
path: root/scripts/automation/trex_control_plane/python_lib/enum34-1.0.4/setup.py
diff options
context:
space:
mode:
authorDan Klein <danklei@cisco.com>2015-08-24 18:44:56 +0300
committerDan Klein <danklei@cisco.com>2015-08-24 18:44:56 +0300
commit98bc71b1c21452c3d868c4a4d418a8aeaa5a43af (patch)
tree2e66b9a775f0a5c545caa76f62890f5a5546e231 /scripts/automation/trex_control_plane/python_lib/enum34-1.0.4/setup.py
parent20eb7d362f9bce1951bd61ad3f78cf8f4267d1d5 (diff)
parent36c6c87fe4380b214f8ff8a45dc0213fa109821c (diff)
Merge branch 'master' into dan_stateless
Diffstat (limited to 'scripts/automation/trex_control_plane/python_lib/enum34-1.0.4/setup.py')
-rwxr-xr-xscripts/automation/trex_control_plane/python_lib/enum34-1.0.4/setup.py44
1 files changed, 0 insertions, 44 deletions
diff --git a/scripts/automation/trex_control_plane/python_lib/enum34-1.0.4/setup.py b/scripts/automation/trex_control_plane/python_lib/enum34-1.0.4/setup.py
deleted file mode 100755
index ecb4944f..00000000
--- a/scripts/automation/trex_control_plane/python_lib/enum34-1.0.4/setup.py
+++ /dev/null
@@ -1,44 +0,0 @@
-import os
-import sys
-from distutils.core import setup
-
-if sys.version_info[:2] < (2, 7):
- required = ['ordereddict']
-else:
- required = []
-
-long_desc = open('enum/doc/enum.rst').read()
-
-setup( name='enum34',
- version='1.0.4',
- url='https://pypi.python.org/pypi/enum34',
- packages=['enum'],
- package_data={
- 'enum' : [
- 'LICENSE',
- 'README',
- 'doc/enum.rst',
- 'doc/enum.pdf',
- 'test_enum.py',
- ]
- },
- license='BSD License',
- description='Python 3.4 Enum backported to 3.3, 3.2, 3.1, 2.7, 2.6, 2.5, and 2.4',
- long_description=long_desc,
- provides=['enum'],
- install_requires=required,
- author='Ethan Furman',
- author_email='ethan@stoneleaf.us',
- classifiers=[
- 'Development Status :: 5 - Production/Stable',
- 'Intended Audience :: Developers',
- 'License :: OSI Approved :: BSD License',
- 'Programming Language :: Python',
- 'Topic :: Software Development',
- 'Programming Language :: Python :: 2.4',
- 'Programming Language :: Python :: 2.5',
- 'Programming Language :: Python :: 2.6',
- 'Programming Language :: Python :: 2.7',
- 'Programming Language :: Python :: 3',
- ],
- )