aboutsummaryrefslogtreecommitdiffstats
path: root/src/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'src/CMakeLists.txt')
-rw-r--r--src/CMakeLists.txt44
1 files changed, 0 insertions, 44 deletions
diff --git a/src/CMakeLists.txt b/src/CMakeLists.txt
deleted file mode 100644
index 5eb40d3..0000000
--- a/src/CMakeLists.txt
+++ /dev/null
@@ -1,44 +0,0 @@
-# Copyright (c) 2018 Intel and/or its affiliates.
-# Licensed under the Apache License, Version 2.0 (the "License");
-# you may not use this file except in compliance with the License.
-# You may obtain a copy of the License at:
-#
-# http://www.apache.org/licenses/LICENSE-2.0
-#
-# Unless required by applicable law or agreed to in writing, software
-# distributed under the License is distributed on an "AS IS" BASIS,
-# WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
-# See the License for the specific language governing permissions and
-# limitations under the License.
-
-message(STATUS "Looking for Hyperscan")
-find_path(HYPERSCAN_INCLUDE_DIR NAMES hs/hs.h)
-find_library(HYPERSCAN_LIB1 NAMES hs)
-find_library(HYPERSCAN_LIB2 NAMES hs_runtime)
-set (HYPERSCAN_LIB ${HYPERSCAN_LIB1} ${HYPERSCAN_LIB2})
-
-if(HYPERSCAN_INCLUDE_DIR AND HYPERSCAN_LIB)
- include_directories(${HYPERSCAN_INCLUDE_DIR})
- add_vpp_plugin(dpi
- SOURCES
- dpi.c
- dpi_api.c
- dpi_cli.c
- dpi_node.c
- protocols/dpi_ssl.c
-
- API_FILES
- dpi.api
-
- INSTALL_HEADERS
- dpi_app_match.h
- dpi.h
-
- LINK_LIBRARIES
- ${HYPERSCAN_LIB}
- )
- message(STATUS "Found Hyperscan in ${HYPERSCAN_INCLUDE_DIR}")
-else()
- message(WARNING "-- Hyperscan not found - dpi_plugin disabled")
-endif()
-