summaryrefslogtreecommitdiffstats
path: root/build-root/deb/debian/rules
diff options
context:
space:
mode:
authorOle Troan <ot@cisco.com>2017-03-20 21:38:37 +0100
committerOle Trøan <otroan@employees.org>2017-03-28 23:37:43 +0000
commit0679760dc54798a47731943b97b1dc5b2a455e3d (patch)
tree3e8e6ceb592ab9a73dd96ea1ede417f5fb622b28 /build-root/deb/debian/rules
parent58f061dca4cb049410a72bb21a9643f7acffa738 (diff)
Python API: Fixup of debian package after cFFI changes.
Change-Id: I4c2a1a818f28d4c6cf52af45f3b7dbfa41d77ccb Signed-off-by: Ole Troan <ot@cisco.com> (cherry picked from commit afaa85f873a7bff1cf1e32c22f909af3018ccfee)
Diffstat (limited to 'build-root/deb/debian/rules')
-rwxr-xr-xbuild-root/deb/debian/rules8
1 files changed, 7 insertions, 1 deletions
diff --git a/build-root/deb/debian/rules b/build-root/deb/debian/rules
index 7046105c10b..3a1dd2905c9 100755
--- a/build-root/deb/debian/rules
+++ b/build-root/deb/debian/rules
@@ -16,9 +16,15 @@ include /usr/share/dpkg/default.mk
# package maintainers to append LDFLAGS
#export DEB_LDFLAGS_MAINT_APPEND = -Wl,--as-needed
+export PYBUILD_NAME = vpp-api-python
+export PYBUILD_DIR = ../../src/vpp-api/python
+export PYBUILD_DESTDIR_python2=debian/vpp-api-python/
+export PYBUILD_DISABLE_python2=test
+export PYBUILD_SYSTEM=distutils
+
# main packaging script based on dh7 syntax
%:
- dh $@ --with systemd,python2
+ dh $@ --with systemd,python2 --buildsystem=pybuild
override_dh_install:
dh_install --exclude .git