aboutsummaryrefslogtreecommitdiffstats
path: root/src/plugins/crypto_ipsecmb/CMakeLists.txt
diff options
context:
space:
mode:
authorBenoît Ganne <bganne@cisco.com>2019-08-09 14:07:23 +0200
committerFlorin Coras <florin.coras@gmail.com>2019-08-09 16:17:43 +0000
commit561be280feb6a10834bf50e0813cc0ad3c635067 (patch)
tree62fad756c0d2ac1c898b3aacd18118c423b33842 /src/plugins/crypto_ipsecmb/CMakeLists.txt
parent243e1933bbecce0a251a5ff71c12dced9e30823f (diff)
crypto: add '-maes' compile switch
AES intrinsics use builtins available only with the -maes and GCC 9 just started to enforce it. Type: fix Change-Id: Ia6825ea3eae7191a4bfee47f9fa93fad16ccf76c Signed-off-by: Benoît Ganne <bganne@cisco.com>
Diffstat (limited to 'src/plugins/crypto_ipsecmb/CMakeLists.txt')
-rw-r--r--src/plugins/crypto_ipsecmb/CMakeLists.txt2
1 files changed, 1 insertions, 1 deletions
diff --git a/src/plugins/crypto_ipsecmb/CMakeLists.txt b/src/plugins/crypto_ipsecmb/CMakeLists.txt
index 86e33a2ca04..59bfe24e990 100644
--- a/src/plugins/crypto_ipsecmb/CMakeLists.txt
+++ b/src/plugins/crypto_ipsecmb/CMakeLists.txt
@@ -33,7 +33,7 @@ if(IPSECMB_INCLUDE_DIR AND IPSECMB_LIB)
${IPSECMB_LINK_FLAGS}
)
- target_compile_options(crypto_ipsecmb_plugin PRIVATE "-march=silvermont")
+ target_compile_options(crypto_ipsecmb_plugin PRIVATE "-march=silvermont" "-maes")
message(STATUS "Intel IPSecMB found: ${IPSECMB_INCLUDE_DIR}")
else()
message(STATUS "Intel IPSecMB not found")