aboutsummaryrefslogtreecommitdiffstats
path: root/packages/vpp_vcl.mk
diff options
context:
space:
mode:
Diffstat (limited to 'packages/vpp_vcl.mk')
-rw-r--r--packages/vpp_vcl.mk11
1 files changed, 6 insertions, 5 deletions
diff --git a/packages/vpp_vcl.mk b/packages/vpp_vcl.mk
index d8c9600..1a7ffce 100644
--- a/packages/vpp_vcl.mk
+++ b/packages/vpp_vcl.mk
@@ -17,6 +17,7 @@ vpp_vcl_install_dir := $(I)/local
vpp_vcl_pkg_deb_name := vpp
vpp_vcl_pkg_deb_dir := $(CURDIR)/vpp/build-root
vpp_vcl_desc := "vcl vpp"
+openssl_install_dir ?= /usr/local/ssl
define vpp_vcl_extract_cmds
@@ -27,16 +28,16 @@ define vpp_vcl_patch_cmds
@echo "--- vpp patching ---"
@cd $(vpp_vcl_src_dir); \
git reset --hard; git clean -f; git checkout master; \
- if [ ! -z $(_VPP_VER) -a $(_VPP_VER) != "master" ]; then \
+ if [ $(_VPP_VER) != "master" ]; then \
echo "--- vpp version: $(_VPP_VER) ---"; \
- git checkout origin/stable/$(_VPP_VER); \
+ git checkout stable/$(_VPP_VER); \
git reset --hard; git clean -f; \
fi
@for f in $(CURDIR)/vpp_patches/common/*.patch ; do \
echo Applying patch: $$(basename $$f) ; \
patch -p1 -d $(vpp_vcl_src_dir) < $$f ; \
done
- @if [ -z $(_VPP_VER) -o $(_VPP_VER) = "master" ]; then \
+ @if [ $(_VPP_VER) = "2005" -o $(_VPP_VER) = "master" ]; then \
echo "--- vpp master ---"; \
for f in $(CURDIR)/vpp_patches/common/master/*.patch ; do \
echo Applying patch: $$(basename $$f) ; \
@@ -65,8 +66,8 @@ endef
define vpp_vcl_build_cmds
@cd $(vpp_vcl_src_dir); \
echo "--- build : $(vpp_vcl_src_dir)"; \
- export OPENSSL_ROOT_DIR=$(I)/local/ssl; \
- export LD_LIBRARY_PATH=$(I)/local/ssl/lib; \
+ export OPENSSL_ROOT_DIR=$(openssl_install_dir); \
+ export LD_LIBRARY_PATH=$(openssl_install_dir)/lib; \
$(MAKE) wipe-release; \
rm -f $(vpp_vcl_pkg_deb_dir)/*.deb; \
$(MAKE) build-release; \