aboutsummaryrefslogtreecommitdiffstats
path: root/longbow/documentation/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'longbow/documentation/CMakeLists.txt')
-rw-r--r--longbow/documentation/CMakeLists.txt8
1 files changed, 4 insertions, 4 deletions
diff --git a/longbow/documentation/CMakeLists.txt b/longbow/documentation/CMakeLists.txt
index 33f92995..61e9f8b6 100644
--- a/longbow/documentation/CMakeLists.txt
+++ b/longbow/documentation/CMakeLists.txt
@@ -5,10 +5,10 @@ if(DOXYGEN_FOUND)
set(GITHUB_REMOTE http://github.com/PARC/LongBow)
configure_file(longbow.doxygen.in config.doxygen @ONLY)
- install(DIRECTORY images/ DESTINATION ${CMAKE_INSTALL_PREFIX}/share/doc/longbow/images)
- install(DIRECTORY doxygen-extras/ DESTINATION ${CMAKE_INSTALL_PREFIX}/share/doc/longbow/doxygen-extras)
- install(DIRECTORY examples/ DESTINATION ${CMAKE_INSTALL_PREFIX}/share/doc/longbow/examples)
- install(FILES DoxygenLayout.xml DESTINATION ${CMAKE_INSTALL_PREFIX}/share/doc/longbow)
+ install(DIRECTORY images/ DESTINATION ${CMAKE_INSTALL_PREFIX}/share/doc/longbow/images COMPONENT documentation)
+ install(DIRECTORY doxygen-extras/ DESTINATION ${CMAKE_INSTALL_PREFIX}/share/doc/longbow/doxygen-extras COMPONENT documentation)
+ install(DIRECTORY examples/ DESTINATION ${CMAKE_INSTALL_PREFIX}/share/doc/longbow/examples COMPONENT documentation)
+ install(FILES DoxygenLayout.xml DESTINATION ${CMAKE_INSTALL_PREFIX}/share/doc/longbow COMPONENT documentation)
set(HTML_PATH ${CMAKE_CURRENT_BINARY_DIR}/generated-documentation/html)