aboutsummaryrefslogtreecommitdiffstats
path: root/vnet/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'vnet/Makefile.am')
-rw-r--r--vnet/Makefile.am16
1 files changed, 16 insertions, 0 deletions
diff --git a/vnet/Makefile.am b/vnet/Makefile.am
index eb7f8ef1..4e4b2c0a 100644
--- a/vnet/Makefile.am
+++ b/vnet/Makefile.am
@@ -350,6 +350,22 @@ nobase_include_HEADERS += \
vnet/ip/udp_packet.h
########################################
+# Bidirectional Forwarding Detection
+########################################
+
+nobase_include_HEADERS += \
+ vnet/bfd/bfd_protocol.h \
+ vnet/bfd/bfd_main.h \
+ vnet/bfd/bfd_api.h \
+ vnet/bfd/bfd_udp.h
+
+libvnet_la_SOURCES += \
+ vnet/bfd/bfd_api.h \
+ vnet/bfd/bfd_udp.c \
+ vnet/bfd/bfd_main.c \
+ vnet/bfd/bfd_protocol.c
+
+########################################
# Layer 3 protocol: IPSec
########################################
if WITH_IPSEC