aboutsummaryrefslogtreecommitdiffstats
path: root/src/plugins/npt66/CMakeLists.txt
diff options
context:
space:
mode:
authorOle Troan <otroan@employees.org>2023-08-17 13:36:08 +0200
committerOle Troan <otroan@employees.org>2023-08-25 09:15:32 +0200
commit6ee3aa41c395d036c8c79a3681cc5ee6bc6fceb9 (patch)
treefcbb367a65e0c9fc932f62fcaf2d46ff622ba9dc /src/plugins/npt66/CMakeLists.txt
parentecb62d2e5d0af14e2de143a729abdf35e132e5d5 (diff)
npt66: network prefix translation for ipv6
This is the initial commit of a NPTv6 (RFC6296) implementation for VPP. It's restricted to a single internal to external binding and runs as an output/input feature on the egress interface. Type: feature Change-Id: I0e3497af97f1ebd99377b84dbf599ecea935ca24 Signed-off-by: Ole Troan <otroan@employees.org>
Diffstat (limited to 'src/plugins/npt66/CMakeLists.txt')
-rw-r--r--src/plugins/npt66/CMakeLists.txt17
1 files changed, 17 insertions, 0 deletions
diff --git a/src/plugins/npt66/CMakeLists.txt b/src/plugins/npt66/CMakeLists.txt
new file mode 100644
index 00000000000..aee784d96f0
--- /dev/null
+++ b/src/plugins/npt66/CMakeLists.txt
@@ -0,0 +1,17 @@
+# SPDX-License-Identifier: Apache-2.0
+# Copyright(c) 2023 Cisco Systems, Inc.
+
+add_vpp_plugin(npt66
+ SOURCES
+ npt66.c
+ npt66_api.c
+ npt66_cli.c
+ npt66_node.c
+
+
+ MULTIARCH_SOURCES
+ npt66_node.c
+
+ API_FILES
+ npt66.api
+)