aboutsummaryrefslogtreecommitdiffstats
path: root/src/vnet/CMakeLists.txt
diff options
context:
space:
mode:
authorNeale Ranns <nranns@cisco.com>2019-02-25 10:28:29 +0000
committerDamjan Marion <dmarion@me.com>2019-02-25 19:37:09 +0000
commit7c44d78ef2e7bf0c8714be4184511ed8f23ff239 (patch)
treeb09f294ebe6365bd38ed0dc7ef4c696cd7630de0 /src/vnet/CMakeLists.txt
parentf883f6a1132ad4bb7aa9d9a79d420274fbcf3b64 (diff)
IKEv2 to plugin
for easy integration with ptoducts running their own Ike stack. Without the VPP IKE plugin loaded, the product is free to handle IKE packets as it pleases. Change-Id: Id0839f4d58b797f4c2da0382eb499fc08b05f66f Signed-off-by: Neale Ranns <nranns@cisco.com>
Diffstat (limited to 'src/vnet/CMakeLists.txt')
-rw-r--r--src/vnet/CMakeLists.txt7
1 files changed, 0 insertions, 7 deletions
diff --git a/src/vnet/CMakeLists.txt b/src/vnet/CMakeLists.txt
index ff817526061..f8dafc05997 100644
--- a/src/vnet/CMakeLists.txt
+++ b/src/vnet/CMakeLists.txt
@@ -492,11 +492,6 @@ list(APPEND VNET_SOURCES
ipsec/esp_decrypt.c
ipsec/ah_decrypt.c
ipsec/ah_encrypt.c
- ipsec/ikev2.c
- ipsec/ikev2_crypto.c
- ipsec/ikev2_cli.c
- ipsec/ikev2_payload.c
- ipsec/ikev2_format.c
ipsec/ipsec_api.c
)
@@ -524,8 +519,6 @@ list(APPEND VNET_HEADERS
ipsec/ipsec_if.h
ipsec/esp.h
ipsec/ah.h
- ipsec/ikev2.h
- ipsec/ikev2_priv.h
)
##############################################################################