aboutsummaryrefslogtreecommitdiffstats
path: root/src/vpp-api/vom/Makefile.am
diff options
context:
space:
mode:
authorNeale Ranns <neale.ranns@cisco.com>2018-04-04 09:34:50 -0700
committerDamjan Marion <dmarion.lists@gmail.com>2018-04-13 08:51:21 +0000
commit25b049484fcf9161edb2c19250066b893c38c264 (patch)
tree69204352a0648cfc4089fa0e37214bffbae61e81 /src/vpp-api/vom/Makefile.am
parent4f8863b21405d1ab3e067e978a60be72a343358b (diff)
GBP V2
update the GBP plugin to implement the full NAT feature set of opflex agent Change-Id: Ic06a039c889445ed0b9087fa1f292634192b0f8d Signed-off-by: Neale Ranns <neale.ranns@cisco.com>
Diffstat (limited to 'src/vpp-api/vom/Makefile.am')
-rw-r--r--src/vpp-api/vom/Makefile.am15
1 files changed, 12 insertions, 3 deletions
diff --git a/src/vpp-api/vom/Makefile.am b/src/vpp-api/vom/Makefile.am
index dad4863c17c..f802849d758 100644
--- a/src/vpp-api/vom/Makefile.am
+++ b/src/vpp-api/vom/Makefile.am
@@ -66,8 +66,14 @@ endif
GBP_SOURCES =
if ENABLE_GBP_PLUGIN
GBP_SOURCES += \
+ gbp_recirc_cmds.cpp \
+ gbp_recirc.cpp \
+ gbp_subnet_cmds.cpp \
+ gbp_subnet.cpp \
gbp_endpoint_cmds.cpp \
gbp_endpoint.cpp \
+ gbp_endpoint_group_cmds.cpp \
+ gbp_endpoint_group.cpp \
gbp_contract_cmds.cpp \
gbp_contract.cpp
endif
@@ -142,7 +148,7 @@ vomincludedir = $(includedir)/vom
ACL_INCLUDES =
if ENABLE_ACL_PLUGIN
-ACL_INCLUDES += \
+ACL_INCLUDES += \
acl_binding.hpp \
acl_ethertype.hpp \
acl_l2_rule.hpp \
@@ -153,7 +159,7 @@ endif
NAT_INCLUDES =
if ENABLE_NAT_PLUGIN
-NAT_INCLUDES += \
+NAT_INCLUDES += \
nat_static.hpp \
nat_binding.hpp
endif
@@ -166,8 +172,11 @@ endif
GBP_INCLUDES =
if ENABLE_GBP_PLUGIN
-GBP_INCLUDES += \
+GBP_INCLUDES += \
gbp_endpoint.hpp \
+ gbp_endpoint_group.hpp \
+ gbp_subnet.hpp \
+ gbp_recirc.hpp \
gbp_contract.hpp
endif