aboutsummaryrefslogtreecommitdiffstats
path: root/src/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'src/configure.ac')
-rw-r--r--src/configure.ac17
1 files changed, 4 insertions, 13 deletions
diff --git a/src/configure.ac b/src/configure.ac
index d28b6c1ccfd..949901c7518 100644
--- a/src/configure.ac
+++ b/src/configure.ac
@@ -304,19 +304,10 @@ AM_COND_IF([ENABLE_MARVELL_PLUGIN],
])
])
-# If cross-compiling, we need external vppapigen and we cannot continue without it
-# For native builds, we just set dependency on vpppaigen binary in top_builddir
-AM_COND_IF([CROSSCOMPILE],
-[
- AC_PATH_PROG([VPPAPIGEN], [vppapigen], [no])
- if test "$VPPAPIGEN" = "no"; then
- AC_MSG_ERROR([Externaly built vppapigen is needed when cross-compiling...])
- fi
-],[
- VPPAPIGEN=\$\(top_builddir\)/vppapigen
-])
-AC_SUBST([VPPAPIGEN])
-
+AC_PATH_PROG([VPPAPIGEN], [vppapigen], [no])
+if test "$VPPAPIGEN" = "no"; then
+ VPPAPIGEN=\$\(top_srcdir\)/tools/vppapigen/vppapigen
+fi
###############################################################################
# JAVA