aboutsummaryrefslogtreecommitdiffstats
path: root/src/plugins/avf/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'src/plugins/avf/CMakeLists.txt')
-rw-r--r--src/plugins/avf/CMakeLists.txt28
1 files changed, 28 insertions, 0 deletions
diff --git a/src/plugins/avf/CMakeLists.txt b/src/plugins/avf/CMakeLists.txt
new file mode 100644
index 00000000000..8f8798bc8ed
--- /dev/null
+++ b/src/plugins/avf/CMakeLists.txt
@@ -0,0 +1,28 @@
+# Copyright (c) 2018 Cisco and/or its affiliates.
+# Licensed under the Apache License, Version 2.0 (the "License");
+# you may not use this file except in compliance with the License.
+# You may obtain a copy of the License at:
+#
+# http://www.apache.org/licenses/LICENSE-2.0
+#
+# Unless required by applicable law or agreed to in writing, software
+# distributed under the License is distributed on an "AS IS" BASIS,
+# WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
+# See the License for the specific language governing permissions and
+# limitations under the License.
+
+add_vpp_plugin(avf_plugin
+ cli.c
+ device.c
+ format.c
+ input.c
+ output.c
+ plugin.c
+ avf_api.c
+ avf.api
+)
+
+vpp_library_set_multiarch_sources(avf_plugin
+ input.c
+ output.c
+)