aboutsummaryrefslogtreecommitdiffstats
path: root/src/plugins/cdp/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'src/plugins/cdp/CMakeLists.txt')
-rw-r--r--src/plugins/cdp/CMakeLists.txt9
1 files changed, 6 insertions, 3 deletions
diff --git a/src/plugins/cdp/CMakeLists.txt b/src/plugins/cdp/CMakeLists.txt
index 036833f5315..9f0b07edcfa 100644
--- a/src/plugins/cdp/CMakeLists.txt
+++ b/src/plugins/cdp/CMakeLists.txt
@@ -11,15 +11,18 @@
# See the License for the specific language governing permissions and
# limitations under the License.
-add_vpp_plugin(cdp_plugin
- cdp.api
+add_vpp_plugin(cdp
+ SOURCES
cdp.c
cdp_input.c
cdp_node.c
cdp_periodic.c
+
+ API_FILES
+ cdp.api
)
-add_vpp_api_test_plugin(cdp_test_plugin
+add_vpp_api_test_plugin(cdp_test
cdp.api
cdp_test.c
)