aboutsummaryrefslogtreecommitdiffstats
path: root/src/plugins/ikev2/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'src/plugins/ikev2/CMakeLists.txt')
-rw-r--r--src/plugins/ikev2/CMakeLists.txt6
1 files changed, 5 insertions, 1 deletions
diff --git a/src/plugins/ikev2/CMakeLists.txt b/src/plugins/ikev2/CMakeLists.txt
index 6f2e5a68153..41292fc476e 100644
--- a/src/plugins/ikev2/CMakeLists.txt
+++ b/src/plugins/ikev2/CMakeLists.txt
@@ -11,7 +11,11 @@
# See the License for the specific language governing permissions and
# limitations under the License.
-add_definitions (-DWITH_LIBSSL=1)
+if(NOT OPENSSL_FOUND)
+ message(WARNING "openssl headers not found - ikev2 plugin disabled")
+ return()
+endif()
+
include_directories(${OPENSSL_INCLUDE_DIR})
add_vpp_plugin(ikev2