aboutsummaryrefslogtreecommitdiffstats
path: root/src/plugins/wireguard/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'src/plugins/wireguard/CMakeLists.txt')
-rwxr-xr-xsrc/plugins/wireguard/CMakeLists.txt4
1 files changed, 4 insertions, 0 deletions
diff --git a/src/plugins/wireguard/CMakeLists.txt b/src/plugins/wireguard/CMakeLists.txt
index db74f9cdce0..6dddc67298d 100755
--- a/src/plugins/wireguard/CMakeLists.txt
+++ b/src/plugins/wireguard/CMakeLists.txt
@@ -16,6 +16,8 @@ if (OPENSSL_VERSION VERSION_LESS 1.1.0)
return()
endif()
+include_directories(${OPENSSL_INCLUDE_DIR})
+
list(APPEND WG_BLAKE_SOURCES
blake/blake2s.h
blake/blake2s.c
@@ -49,6 +51,8 @@ add_vpp_plugin(wireguard
wireguard_index_table.h
wireguard_api.c
+ LINK_LIBRARIES ${OPENSSL_LIBRARIES}
+
API_FILES
wireguard.api