summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorMauro Sardara <msardara+fdio@cisco.com>2017-02-24 19:27:34 +0100
committerMauro Sardara <msardara+fdio@cisco.com>2017-02-24 18:44:32 +0000
commit6b8a37403caf8830e85476343ad4be13c7372537 (patch)
treeb19a9d10d00fc177590e1237e6cc4a7da5f246bf /CMakeLists.txt
parentb5439cd1b3d81f71d2d198f4bd3b29c2bbee2308 (diff)
- Added missing dependency "ccnx-portal-rta", still needed for the control messages
- Fixed little typo for being compliant with the code style - Removed include statements of deprecated library "ccnx-portal" - added level of optimization of 3 by default Change-Id: Id353e58fa1e7eeeb90bdf19ec7fd921876ab12c4 Signed-off-by: Mauro Sardara <msardara+fdio@cisco.com>
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt2
1 files changed, 1 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 9e98174c..5e3320a2 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -74,7 +74,7 @@ find_package(Boost 1.54.0 COMPONENTS system REQUIRED)
include_directories(SYSTEM ${Boost_INCLUDE_DIR})
set(CMAKE_VERBOSE_MAKEFILE off)
-set(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -std=c++11 -Wall -fpermissive")
+set(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -std=c++11 -Wall -fpermissive -O3")
set(LIBRARIES
${CCNX_PORTAL_LIBRARIES}