aboutsummaryrefslogtreecommitdiffstats
path: root/apps/consumers/CMakeLists.txt
diff options
context:
space:
mode:
authorMauro Sardara <msardara+fdio@cisco.com>2018-02-23 15:25:32 +0100
committerMauro Sardara <msardara+fdio@cisco.com>2018-02-23 18:34:34 +0100
commit95f3619c8be677bcd9cf3bb320c7262bbe6dc44b (patch)
treedce5ef7a24e987797f79a90a6009b40e667e1be5 /apps/consumers/CMakeLists.txt
parent9b35eadcca5b19078c55a10e68abeace81cf032c (diff)
Added native PING application
Change-Id: If76818fdc90e7223e811ece0c21f8a7c67defa4c Signed-off-by: Mauro Sardara <msardara+fdio@cisco.com>
Diffstat (limited to 'apps/consumers/CMakeLists.txt')
-rwxr-xr-xapps/consumers/CMakeLists.txt6
1 files changed, 6 insertions, 0 deletions
diff --git a/apps/consumers/CMakeLists.txt b/apps/consumers/CMakeLists.txt
index 757d0219..4cf2d2a2 100755
--- a/apps/consumers/CMakeLists.txt
+++ b/apps/consumers/CMakeLists.txt
@@ -15,6 +15,7 @@ cmake_minimum_required(VERSION 3.2)
set(CONSUMER_SOURCE_FILES icnet_consumer_test.cc)
set(CONSUMER__HELLO_WORLD_SOURCE_FILES icnet_consumer_hello_world.cc)
+set(CONSUMER_PING_CLIENT_SOURCE_FILES icnet_ping_client.cc)
add_executable(consumer-test ${CONSUMER_SOURCE_FILES})
@@ -25,3 +26,8 @@ add_executable(consumer-hello-world ${CONSUMER__HELLO_WORLD_SOURCE_FILES})
target_link_libraries(consumer-hello-world icnet ${CMAKE_THREAD_LIBS_INIT} ${Boost_LIBRARIES})
install(TARGETS consumer-hello-world DESTINATION ${CMAKE_INSTALL_PREFIX}/bin COMPONENT library)
+
+add_executable(icnet-ping-client ${CONSUMER_PING_CLIENT_SOURCE_FILES})
+
+target_link_libraries(icnet-ping-client icnet ${CMAKE_THREAD_LIBS_INIT} ${Boost_LIBRARIES})
+install(TARGETS icnet-ping-client DESTINATION ${CMAKE_INSTALL_PREFIX}/bin COMPONENT library)