aboutsummaryrefslogtreecommitdiffstats
path: root/apps/iping/CMakeLists.txt
diff options
context:
space:
mode:
authorMauro Sardara <msardara+fdio@cisco.com>2018-02-26 11:01:44 +0100
committerMauro Sardara <msardara+fdio@cisco.com>2018-02-26 11:13:24 +0100
commit82a8803fc86680a149d43181f43b1ac4f69a359d (patch)
treee0bfc826179caeb193550a624f008f55e1ad20cb /apps/iping/CMakeLists.txt
parent95f3619c8be677bcd9cf3bb320c7262bbe6dc44b (diff)
Removed old iPing application.
New apps added: iping-client: ping client that provides statistics regarding the rtt and the losses. It allows to configure the ping interval, the interest lifetime, the ttl and the name. iping-server: simple server replying to icnet-ping-client. It allows to configure the reply size and the name. Change-Id: I6b08333147acfaffd8becacb48f27f6c42dbeeb9 Signed-off-by: Mauro Sardara <msardara+fdio@cisco.com>
Diffstat (limited to 'apps/iping/CMakeLists.txt')
-rw-r--r--apps/iping/CMakeLists.txt50
1 files changed, 0 insertions, 50 deletions
diff --git a/apps/iping/CMakeLists.txt b/apps/iping/CMakeLists.txt
deleted file mode 100644
index b2fa4874..00000000
--- a/apps/iping/CMakeLists.txt
+++ /dev/null
@@ -1,50 +0,0 @@
-# Copyright (c) 2017 Cisco and/or its affiliates.
-# Licensed under the Apache License, Version 2.0 (the "License");
-# you may not use this file except in compliance with the License.
-# You may obtain a copy of the License at:
-#
-# http://www.apache.org/licenses/LICENSE-2.0
-#
-# Unless required by applicable law or agreed to in writing, software
-# distributed under the License is distributed on an "AS IS" BASIS,
-# WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
-# See the License for the specific language governing permissions and
-# limitations under the License.
-
-cmake_minimum_required(VERSION 3.2)
-
-set(CMAKE_C_STANDARD 99)
-set(CMAKE_C_STANDARD_REQUIRED ON)
-
-if ($ENV{CCNX_HOME})
- set(CCNX_HOME $ENV{CCNX_HOME})
-else ($ENV{CCNX_HOME})
- set(CCNX_HOME /usr/local)
-endif ($ENV{CCNX_HOME})
-
-set(CMAKE_C_FLAGS "${CMAKE_C_FLAGS} -Wall -D_GNU_SOURCE")
-
-set(CCNX_LIBRARIES longbow longbow-ansiterm parc ccnx_common ccnx_api_portal ccnx_transport_rta ccnx_api_control ccnx_api_notify)
-
-set(CMAKE_INSTALL_RPATH "${CMAKE_INSTALL_PREFIX}/lib")
-
-set(CCNX_PING_CLIENT_SOURCE_FILES
- iPing_Client.c
- iPing_Common.c
- iPing_Stats.c)
-
-set(CCNX_PING_SERVER_SOURCE_FILES
- iPing_Server.c
- iPing_Common.c)
-
-include_directories(${CCNX_HOME}/include)
-
-link_directories(${CCNX_HOME}/lib)
-
-add_executable(iPing_Client ${CCNX_PING_CLIENT_SOURCE_FILES})
-target_link_libraries(iPing_Client ${CCNX_LIBRARIES})
-install(TARGETS iPing_Client RUNTIME DESTINATION bin COMPONENT library)
-
-add_executable(iPing_Server ${CCNX_PING_SERVER_SOURCE_FILES})
-target_link_libraries(iPing_Server ${CCNX_LIBRARIES})
-install(TARGETS iPing_Server RUNTIME DESTINATION bin COMPONENT library)