aboutsummaryrefslogtreecommitdiffstats
path: root/apps/producers/CMakeLists.txt
diff options
context:
space:
mode:
authorMauro Sardara <msardara+fdio@cisco.com>2018-02-26 11:01:44 +0100
committerMauro Sardara <msardara+fdio@cisco.com>2018-02-26 11:13:24 +0100
commit82a8803fc86680a149d43181f43b1ac4f69a359d (patch)
treee0bfc826179caeb193550a624f008f55e1ad20cb /apps/producers/CMakeLists.txt
parent95f3619c8be677bcd9cf3bb320c7262bbe6dc44b (diff)
Removed old iPing application.
New apps added: iping-client: ping client that provides statistics regarding the rtt and the losses. It allows to configure the ping interval, the interest lifetime, the ttl and the name. iping-server: simple server replying to icnet-ping-client. It allows to configure the reply size and the name. Change-Id: I6b08333147acfaffd8becacb48f27f6c42dbeeb9 Signed-off-by: Mauro Sardara <msardara+fdio@cisco.com>
Diffstat (limited to 'apps/producers/CMakeLists.txt')
-rwxr-xr-xapps/producers/CMakeLists.txt6
1 files changed, 3 insertions, 3 deletions
diff --git a/apps/producers/CMakeLists.txt b/apps/producers/CMakeLists.txt
index 2d97eb2e..10353057 100755
--- a/apps/producers/CMakeLists.txt
+++ b/apps/producers/CMakeLists.txt
@@ -25,13 +25,13 @@ set(PRODUCER_PING_SOURCE_FILES
add_executable(producer-test ${PRODUCER_SOURCE_FILES})
add_executable(producer-hello-world ${PRODUCER_HELLO_WORLD_SOURCE_FILES})
-add_executable(icnet-ping-server ${PRODUCER_PING_SOURCE_FILES})
+add_executable(iping-server ${PRODUCER_PING_SOURCE_FILES})
target_link_libraries(producer-test icnet ${CMAKE_THREAD_LIBS_INIT} ${Boost_LIBRARIES})
target_link_libraries(producer-hello-world icnet ${CMAKE_THREAD_LIBS_INIT} ${Boost_LIBRARIES})
-target_link_libraries(icnet-ping-server icnet ${CMAKE_THREAD_LIBS_INIT} ${Boost_LIBRARIES})
+target_link_libraries(iping-server icnet ${CMAKE_THREAD_LIBS_INIT} ${Boost_LIBRARIES})
install(TARGETS producer-test DESTINATION ${CMAKE_INSTALL_PREFIX}/bin COMPONENT library)
install(TARGETS producer-hello-world DESTINATION ${CMAKE_INSTALL_PREFIX}/bin COMPONENT library)
-install(TARGETS icnet-ping-server DESTINATION ${CMAKE_INSTALL_PREFIX}/bin COMPONENT library)
+install(TARGETS iping-server DESTINATION ${CMAKE_INSTALL_PREFIX}/bin COMPONENT library)