aboutsummaryrefslogtreecommitdiffstats
path: root/apps/producers/CMakeLists.txt
diff options
context:
space:
mode:
authorMauro Sardara <msardara+fdio@cisco.com>2018-02-23 15:25:32 +0100
committerMauro Sardara <msardara+fdio@cisco.com>2018-02-23 18:34:34 +0100
commit95f3619c8be677bcd9cf3bb320c7262bbe6dc44b (patch)
treedce5ef7a24e987797f79a90a6009b40e667e1be5 /apps/producers/CMakeLists.txt
parent9b35eadcca5b19078c55a10e68abeace81cf032c (diff)
Added native PING application
Change-Id: If76818fdc90e7223e811ece0c21f8a7c67defa4c Signed-off-by: Mauro Sardara <msardara+fdio@cisco.com>
Diffstat (limited to 'apps/producers/CMakeLists.txt')
-rwxr-xr-xapps/producers/CMakeLists.txt7
1 files changed, 7 insertions, 0 deletions
diff --git a/apps/producers/CMakeLists.txt b/apps/producers/CMakeLists.txt
index 37366362..2d97eb2e 100755
--- a/apps/producers/CMakeLists.txt
+++ b/apps/producers/CMakeLists.txt
@@ -20,11 +20,18 @@ set(PRODUCER_SOURCE_FILES
set(PRODUCER_HELLO_WORLD_SOURCE_FILES
icnet_producer_hello_world.cc)
+set(PRODUCER_PING_SOURCE_FILES
+ icnet_ping_server.cc)
+
add_executable(producer-test ${PRODUCER_SOURCE_FILES})
add_executable(producer-hello-world ${PRODUCER_HELLO_WORLD_SOURCE_FILES})
+add_executable(icnet-ping-server ${PRODUCER_PING_SOURCE_FILES})
+
target_link_libraries(producer-test icnet ${CMAKE_THREAD_LIBS_INIT} ${Boost_LIBRARIES})
target_link_libraries(producer-hello-world icnet ${CMAKE_THREAD_LIBS_INIT} ${Boost_LIBRARIES})
+target_link_libraries(icnet-ping-server icnet ${CMAKE_THREAD_LIBS_INIT} ${Boost_LIBRARIES})
install(TARGETS producer-test DESTINATION ${CMAKE_INSTALL_PREFIX}/bin COMPONENT library)
install(TARGETS producer-hello-world DESTINATION ${CMAKE_INSTALL_PREFIX}/bin COMPONENT library)
+install(TARGETS icnet-ping-server DESTINATION ${CMAKE_INSTALL_PREFIX}/bin COMPONENT library)