aboutsummaryrefslogtreecommitdiffstats
path: root/libccnx-common/ccnx/common/CMakeLists.txt
diff options
context:
space:
mode:
authorMauro Sardara <msardara+fdio@cisco.com>2017-03-27 16:23:55 +0200
committerMauro Sardara <msardara+fdio@cisco.com>2017-03-27 14:36:47 +0000
commit63a79c98bbc82faaa11280894041436443ae8f1d (patch)
tree789cebc90e4c65d37149270e03474a3815833a5b /libccnx-common/ccnx/common/CMakeLists.txt
parent6d4b6878ceff22f9ec8d8e9423214f9666007472 (diff)
Adding support for creating DEB and RPM packages
Change-Id: I4c02d679d24dac82a8848e09ada4e5555653c57a Signed-off-by: Mauro Sardara <msardara+fdio@cisco.com>
Diffstat (limited to 'libccnx-common/ccnx/common/CMakeLists.txt')
-rw-r--r--libccnx-common/ccnx/common/CMakeLists.txt14
1 files changed, 7 insertions, 7 deletions
diff --git a/libccnx-common/ccnx/common/CMakeLists.txt b/libccnx-common/ccnx/common/CMakeLists.txt
index 34e71e79..3f21b095 100644
--- a/libccnx-common/ccnx/common/CMakeLists.txt
+++ b/libccnx-common/ccnx/common/CMakeLists.txt
@@ -257,13 +257,13 @@ foreach(lib ${libccnx_commonLibraries})
set_property(TARGET ${lib} PROPERTY C_STANDARD 99)
endforeach()
-install(FILES ${CORE_HDRS} DESTINATION include/ccnx/common )
-install(FILES ${INTERNAL_HDRS} DESTINATION include/ccnx/common/internal )
-install(FILES ${VALIDATION_HDRS} DESTINATION include/ccnx/common/validation )
-install(FILES ${CODEC_HDRS} DESTINATION include/ccnx/common/codec )
-install(FILES ${TESTDATA_HDRS} DESTINATION include/ccnx/common/codec/testdata )
-install(FILES ${SCHEMAV1_HDRS} DESTINATION include/ccnx/common/codec/schema_v1 )
-install(FILES ${SCHEMAV1_TESTDATA_HDRS} DESTINATION include/ccnx/common/codec/schema_v1/testdata )
+install(FILES ${CORE_HDRS} DESTINATION ${CMAKE_INSTALL_PREFIX}/include/ccnx/common )
+install(FILES ${INTERNAL_HDRS} DESTINATION ${CMAKE_INSTALL_PREFIX}/include/ccnx/common/internal )
+install(FILES ${VALIDATION_HDRS} DESTINATION ${CMAKE_INSTALL_PREFIX}/include/ccnx/common/validation )
+install(FILES ${CODEC_HDRS} DESTINATION ${CMAKE_INSTALL_PREFIX}/include/ccnx/common/codec )
+install(FILES ${TESTDATA_HDRS} DESTINATION ${CMAKE_INSTALL_PREFIX}/include/ccnx/common/codec/testdata )
+install(FILES ${SCHEMAV1_HDRS} DESTINATION ${CMAKE_INSTALL_PREFIX}/include/ccnx/common/codec/schema_v1 )
+install(FILES ${SCHEMAV1_TESTDATA_HDRS} DESTINATION ${CMAKE_INSTALL_PREFIX}/include/ccnx/common/codec/schema_v1/testdata )
#add_subdirectory(test)
#add_subdirectory(validation/test)