aboutsummaryrefslogtreecommitdiffstats
path: root/libccnx-common/ccnx/common/test/CMakeLists.txt
diff options
context:
space:
mode:
authorLuca Muscariello <lumuscar+fdio@cisco.com>2017-02-23 20:44:26 +0100
committerLuca Muscariello <lumuscar+fdio@cisco.com>2017-02-23 19:51:14 +0000
commitd18ae43123fcd7604d1c36a1ec8450dbe6071824 (patch)
tree2d49fc3aabd0f2607251c854565648d47b56b2e9 /libccnx-common/ccnx/common/test/CMakeLists.txt
parent9b30fc10fb1cbebe651e5a107e8ca5b24de54675 (diff)
Initial commit: ccnxlibs.
Change-Id: I1b376527a7dd01a6b9e083a6cb646955902f45c0 Signed-off-by: Luca Muscariello <lumuscar+fdio@cisco.com>
Diffstat (limited to 'libccnx-common/ccnx/common/test/CMakeLists.txt')
-rw-r--r--libccnx-common/ccnx/common/test/CMakeLists.txt29
1 files changed, 29 insertions, 0 deletions
diff --git a/libccnx-common/ccnx/common/test/CMakeLists.txt b/libccnx-common/ccnx/common/test/CMakeLists.txt
new file mode 100644
index 00000000..4cf70a14
--- /dev/null
+++ b/libccnx-common/ccnx/common/test/CMakeLists.txt
@@ -0,0 +1,29 @@
+# Enable gcov output for the tests
+add_definitions(--coverage)
+set(CMAKE_EXE_LINKER_FLAGS ${CMAKE_EXE_LINKER_FLAGS} " --coverage")
+
+configure_file(data.json data.json COPYONLY)
+
+set(TestsExpectedToPass
+ test_ccnx_ContentObject
+ test_ccnx_Interest
+ test_ccnx_InterestPayloadId
+ test_ccnx_InterestReturn
+ test_ccnx_KeyLocator
+ test_ccnx_KeystoreUtilities
+ test_ccnx_Link
+ test_ccnx_Manifest
+ test_ccnx_ManifestHashGroup
+ test_ccnx_Name
+ test_ccnx_NameLabel
+ test_ccnx_NameSegment
+ test_ccnx_NameSegmentNumber
+ test_ccnx_TimeStamp
+ test_ccnx_WireFormatMessage
+)
+
+
+foreach(test ${TestsExpectedToPass})
+ AddTest(${test})
+endforeach()
+