aboutsummaryrefslogtreecommitdiffstats
path: root/libccnx-transport-rta/ccnx/api/control/test/CMakeLists.txt
diff options
context:
space:
mode:
authorMichele Papalini <micpapal+fdio@cisco.com>2017-02-24 08:00:13 +0000
committerGerrit Code Review <gerrit@fd.io>2017-02-24 08:00:13 +0000
commit6d4b6878ceff22f9ec8d8e9423214f9666007472 (patch)
treefa27e0c747676519cb87ff8448bfed62fce5009d /libccnx-transport-rta/ccnx/api/control/test/CMakeLists.txt
parentf28308bd99381ef5f1e178e2e1f870f245e35873 (diff)
parentd18ae43123fcd7604d1c36a1ec8450dbe6071824 (diff)
Merge "Initial commit: ccnxlibs." into ccnxlibs/master
Diffstat (limited to 'libccnx-transport-rta/ccnx/api/control/test/CMakeLists.txt')
-rw-r--r--libccnx-transport-rta/ccnx/api/control/test/CMakeLists.txt36
1 files changed, 36 insertions, 0 deletions
diff --git a/libccnx-transport-rta/ccnx/api/control/test/CMakeLists.txt b/libccnx-transport-rta/ccnx/api/control/test/CMakeLists.txt
new file mode 100644
index 00000000..a573213c
--- /dev/null
+++ b/libccnx-transport-rta/ccnx/api/control/test/CMakeLists.txt
@@ -0,0 +1,36 @@
+# Enable gcov output for the tests
+add_definitions(--coverage)
+set(CMAKE_EXE_LINKER_FLAGS ${CMAKE_EXE_LINKER_FLAGS} " --coverage")
+
+set(TestsExpectedToPass
+ test_cpi_Acks
+ test_cpi_Address
+ test_cpi_AddressList
+ test_cpi_CancelFlow
+ test_cpi_Connection
+ test_cpi_ConnectionEthernet
+ test_cpi_ConnectionList
+ test_cpi_ControlMessage
+ test_cpi_ControlFacade
+ test_cpi_Interface
+ test_cpi_InterfaceSet
+ test_cpi_InterfaceTypes
+ test_cpi_InterfaceGeneric
+ test_cpi_InterfaceEthernet
+ test_cpi_InterfaceIPTunnel
+ test_cpi_InterfaceIPTunnelList
+ test_cpi_Forwarding
+ test_cpi_Listener
+ test_cpi_ManageLinks
+ test_cpi_NameRouteType
+ test_cpi_Registration
+ test_cpi_RouteEntry
+ test_cpi_RouteEntryList
+ test_controlPlaneInterface
+)
+
+
+foreach(test ${TestsExpectedToPass})
+ AddTest(${test})
+endforeach()
+