aboutsummaryrefslogtreecommitdiffstats
path: root/libparc/parc/CMakeLists.txt
diff options
context:
space:
mode:
authorAngelo Mantellini <manangel@cisco.com>2019-09-20 16:58:12 +0200
committerAngelo Mantellini <manangel@cisco.com>2019-09-26 16:27:07 +0200
commite739ca2affa1237089857b5e1c87afeac25449aa (patch)
tree06dc74c35209a6ae8e7d9756cee0ed6e782f7153 /libparc/parc/CMakeLists.txt
parent79445435d86aea92f85a1c0398ccada48af578e5 (diff)
[HICN-284] Android log for libparc
Signed-off-by: Angelo Mantellini <manangel@cisco.com> Change-Id: Iaec9ec7cd125eb4f9a391cd917a85a972e1c50b2
Diffstat (limited to 'libparc/parc/CMakeLists.txt')
-rw-r--r--libparc/parc/CMakeLists.txt2
1 files changed, 1 insertions, 1 deletions
diff --git a/libparc/parc/CMakeLists.txt b/libparc/parc/CMakeLists.txt
index df582a35..62c81b6e 100644
--- a/libparc/parc/CMakeLists.txt
+++ b/libparc/parc/CMakeLists.txt
@@ -392,7 +392,7 @@ if("${CMAKE_CXX_COMPILER_ID}" STREQUAL "AppleClang" OR COMPILE_FOR_IOS)
set(CMAKE_SHARED_LIBRARY_CREATE_C_FLAGS "${CMAKE_SHARED_LIBRARY_CREATE_C_FLAGS} -undefined dynamic_lookup")
message( "-- Set \"-undefined dynamic_lookup\" for shared libraries")
endif()
-if(COMPILE_FOR_IOS OR ANDROID_API)
+if(COMPILE_FOR_IOS OR ${CMAKE_SYSTEM_NAME} STREQUAL "Android")
add_library(parc STATIC ${LIBPARC_SOURCE_FILES} ${LIBEVENT_LIBRARIES} ${OPENSSL_LIBRARIES})
target_link_libraries(parc ${LIBEVENT_LIBRARIES})
target_link_libraries(parc ${OPENSSL_LIBRARIES})